BWCA Garmin GPSmap 62 software update killed it Boundary Waters Group Forum: GPS
Chat Rooms (0 Chatting)  |  Search  |   Login/Join
* For the benefit of the community, commercial posting is not allowed.
Boundary Waters Quetico Forum
   Group Forum: GPS
      Garmin GPSmap 62 software update killed it     

Author

Text

Hank
distinguished member (224)distinguished memberdistinguished memberdistinguished member
 
03/22/2021 02:14PM  
Well I decided after many years to update the software on my 62. Something happened and now it turns on then slowly fades out. I won't boot correctly. I replaced the batteries and all that and spent a lot of time on garmin chat.

The tech had me remove a bunch of files, but it still won't boot properly. He said it is to old and there is nothing I can do. Anyone have any suggestions? I should have know better than to mess with it, but I'm taking my daughter up this July and wanted to make sure it was up to date. Sigh.
 
      Print Top Bottom Previous Next
schweady
distinguished member(7734)distinguished memberdistinguished memberdistinguished memberdistinguished memberpower member
 
03/27/2021 10:25AM  
The 62 is certainly not "too old."

Have you tried a hard reset? The bad news: this will delete all tracks, routes, and waypoints on the unit. But, it will restore all settings to the factory defaults, which may bring it back to life. Birdseye imagery does not get deleted nor does any information on a micro SD card. (But, I would suggest removing any card before beginning, in any case. A bad card could actually be the only problem.)

Hard Reset:
With the unit off, hold down the Enter + Page + Power buttons simultaneously.
Release the Power button once you see the Garmin logo during startup. Keep you fingers on Enter + Page.
It will display a screen asking you to delete all user info. Enter Yes to proceed.

Good luck.

PS: Unfortunately, I have had some bad advice in Chat from Garmin Tech Support regarding deleting files, resulting in permanently disabling my original Upper Midwest Fishing Guide microSD chip. They sent me a new Bluechart G3 chip to compensate, but that didn't work with BaseCamp on my Mac, and, they discontinued development of HomePort Mac, the only app available to me that could read similar charts, so I got another UMFG chip on eBay for home computer use.

 
Hank
distinguished member (224)distinguished memberdistinguished memberdistinguished member
 
04/15/2021 04:33PM  
Thanks so much schweady!

I tried the hard reset but no luck. I wish I never tried to update the software.

I tripped for years without a gps so I thought I’d just go back to map and compass. I recently downloaded gaiagps on my iPhone and am really impressed with it. I’ve had it running recently on a few hiking trips at it seems to be spot on. I downloaded the BWCA specific maps that have some campsites and all the portages. I guess I’ll use that this year if I get turned around. I’m kind of disappointed with Garmin at this point.

Thanks again!
 
04/15/2021 05:33PM  
I have updated a few 62 units all worked fine. If you think it a lost cause send it to me and I'll give it a shot.

Ken Martinson
124 Meadowlark DR Apt.6
Burlington WI 53105

butthead
 
Hank
distinguished member (224)distinguished memberdistinguished memberdistinguished member
 
04/27/2021 11:29AM  
Thanks Bunches Ken!

I'll send it along to you to see if you can do anything with it.

Best,

Hank (Steve Harmon)

 
04/27/2021 12:45PM  
Sure enough Hank!
Hell it gives me something to do, other than play with my truck!

butthead
 
05/11/2021 04:37PM  
Hank did sent it to me. I could hook it to a computer and read the files, plug in via USB and hold the up arrow button to bring up USB drive mode. I coppied the files for backup, then tried swapping with a backup from my own files, no change. Garmin update detects it and offers an updated software, as will Basecamp. The update installs but no joy. I could not start it on it's own, just the Garmin logo for a time then blank black screen. Resets did nothing. I do not like to fail but this did have issues past my ability.

butthead
 
      Print Top Bottom Previous Next